• 欢迎访问金笔头博客,这是一个菜鸟(伪)程序员的自留地,欢迎访问我的github:点击进入

​易语言置托盘图标示例代码

易语言 eason 1682次浏览 0个评论 扫描二维码

​易语言置托盘图标示例代码


.版本 2

.子程序 __启动窗口_位置被改变

.如果真 (_启动窗口.位置 = 2)

    _启动窗口.可视 = 假

    置托盘图标 (#logo, “金笔头博客VPN连接工具V1.0”)

.如果真结束

.子程序 __启动窗口_托盘事件

.参数 操作类型, 整数型

.如果真 (操作类型 = #单击右键)

    弹出托盘菜单 (托盘菜单)

.如果真结束

.如果真 (操作类型 = #单击左键)

    .如果 (_启动窗口.可视 = 假)

        _启动窗口.可视 = 真

        _启动窗口.位置 = 1

        置托盘图标 (“”, )

    .否则

        _启动窗口.可视 = 假

    .如果结束

.如果真结束

.子程序 _显示_被选择

_启动窗口.可视 = 真

_启动窗口.位置 = 1

置托盘图标 (“”, )

.子程序 _退出_被选择

.如果 (按钮_连接or断开.标题 = “连接”)

    销毁 ()

.否则

    _按钮_连接or断开_被单击 ()

    销毁 ()

.如果结束

.子程序 _关于_被选择

信息框 (“金笔头博客版权所有!2015-09-13” + #换行符 + “http://jinbitou.net”, 64, “关于:”, )

.子程序 __启动窗口_窗口可否被关闭, 逻辑型

.如果 (信息框 (“你确定要退出吗?”, #是否钮 + #询问图标 + #默认按钮二 + #程序等待, “确认:”, ) = #是钮)

    销毁 ()

.否则

    返回 (假)

.如果结束


金笔头博客, 版权所有丨如未注明 , 均为原创, 转载请注明​易语言置托盘图标示例代码
喜欢 (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址